Infrasec Service Disruption (Sitoo POS users in Sweden using a control unit from Infrasec are affected)

Incident Report for Sitoo

Resolved

Infrasec are now up and running so the operation should be normal again.
Posted Nov 10, 2025 - 11:35 CET

Identified

We have identified an issue with Infrasec who handles the Control Unit for a few of our customers operating in Sweden. Until then you unfortunately will have to charge the customers outside of the Sitoo POS app (for instance with cash or a Swish number) and write a physical receipt.

NOTE! This in only relevant for our customers operating in Sweden and dependent upon the Control Unit provided by Infrasec.
Posted Nov 10, 2025 - 11:32 CET
This incident affected: 3rd Party Integrations.