Switchboard for Sitoo Support is down
Incident Report for Sitoo
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 13:33 CET
Update
We are continuing to investigate this issue.
Posted Jan 11, 2024 - 13:32 CET
Investigating
We are currently experiencing issues with the switchboard for Sitoo Support. Our provider has been notified and is working on it. Sitoo Support is still reachable at: https://support.sitoo.com/hc/en-us/requests/new.
Posted Jan 11, 2024 - 12:41 CET
This incident affected: Sitoo Support Services.