Voyado Service Disruption (CRM used by several Sitoo Customers)
Incident Report for Sitoo
Resolved
Voyado reports that the incident has been resolved.
Posted Apr 16, 2024 - 13:28 CEST
Identified
Voyado, who is a CRM used by several Sitoo customers have an ongoing incident. For direct status please see: https://status.voyado.com/
Posted Apr 16, 2024 - 10:37 CEST
This incident affected: 3rd Party Integrations.