Sitoo POS Android App not available in Google Play Store

Incident Report for Sitoo

Resolved

This has been resolved.
Posted Sep 13, 2023 - 13:01 CEST

Investigating

Sitoo POS Android app is currently not available from Google Play Store and Sitoo is currently working hard to get it back.
Posted Sep 13, 2023 - 10:32 CEST
This incident affected: Sitoo POS Android.