Investigating Issue with Z Reports Number Series

Incident Report for Sitoo

Resolved

This incident has been resolved with the new version 1.93. We will continue to monitor the status.
Posted Mar 14, 2025 - 10:21 CET

Monitoring

Version 1.93 is now available in the App Store with the following fixes:
• CRM V2 – Customer Addition to Cart
Resolved an issue preventing customers from being added to the cart when the CRM V2 SPI did not return customer transactions.
• Z-Report Numbering
Fixed a bug causing the Z-report ID numbering to reset to 1 instead of continuing sequentially.

We will continue monitoring this closely and provide updates as needed.
Posted Mar 13, 2025 - 20:36 CET

Update

We are actively working on resolving the issue and will continue to provide updates as soon as more information becomes available.
Posted Mar 13, 2025 - 18:14 CET

Identified

The root cause has been identified, and we are working on a fix.
Posted Mar 13, 2025 - 14:31 CET

Investigating

We're currently investigating two related issues affecting Z reports:
1) Z report number series are restarting from 1 unexpectedly (starting from version 1.91).
2) Users who closed Z reports last night may receive prompts to close again, causing the number series and grand totals to reset.
Note: Journal data remains accurate. This issue only impacts the Z report numbering.
The 3 grand total fields in the journal data are also affected, as they reflect the information on the Z reports (moneygrandtotalsales, moneygrandtotalrefund, moneygrandtotalnet)

We strongly reccomend not to upgrade from version 1.90 until a fix is released
Posted Mar 13, 2025 - 13:31 CET
This incident affected: Sitoo POS iOS.