Switchboard for Sitoo Support is down
Incident Report for Sitoo
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 16:43 CET
Update
We are continuing to monitor for any further issues.
Posted Jan 18, 2024 - 16:35 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2024 - 16:34 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2024 - 17:46 CET
Investigating
We are currently experiencing issues with the switchboard for Sitoo Support. Our provider has been notified and is working on it. Sitoo international support it still reachable at +46 8 5000 9390.
Posted Jan 11, 2024 - 16:51 CET
This incident affected: Sitoo Support Services.